hasufell-repository/packages/games-strategy/freeorion/files/freeorion-0.4.7.1-Fix-compa...

38 lines
981 B
Diff

Upstream: yes, will be in 0.4.8
From 618568705a0ca37ffd9e88d08cda3d3601d01d98 Mon Sep 17 00:00:00 2001
From: Dmitry Marakasov <amdmi3@amdmi3.ru>
Date: Fri, 29 Jun 2018 19:42:52 +0300
Subject: [PATCH] Fix compatibility with boost 1.67.0
---
CMakeLists.txt | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b2fe63a7..4d26e06a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -204,11 +204,17 @@ find_package(Boost ${MINIMUM_BOOST_VERSION}
log_setup
regex
serialization
- python
signals
system
thread
REQUIRED)
+if(${Boost_VERSION} GREATER 106699) # boost >= 1.67
+ find_package(Boost COMPONENTS python27 REQUIRED)
+ set(Boost_PYTHON_LIBRARY ${Boost_PYTHON27_LIBRARY})
+else()
+ find_package(Boost COMPONENTS python REQUIRED)
+endif()
+
find_package(ZLIB REQUIRED)
if(NOT BUILD_HEADLESS)
find_package(Freetype REQUIRED)
--
2.18.0