forked from hasufell/hasufell-repository
47 lines
1.1 KiB
Diff
47 lines
1.1 KiB
Diff
From cf972fb6eacd32a2d92660ce072b4fa332bdbea0 Mon Sep 17 00:00:00 2001
|
|
From: Julian Ospald <hasufell@posteo.de>
|
|
Date: Sat, 1 Oct 2016 13:50:26 +0200
|
|
Subject: [PATCH] Fix parallel build
|
|
Upstream: submitted, https://github.com/matricks/bam/pull/101
|
|
|
|
---
|
|
Makefile | 12 ++++++------
|
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 8ff4b72..d804874 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -16,7 +16,7 @@ CFLAGS += $(LUA_CFLAGS)
|
|
|
|
|
|
# objects
|
|
-TARGETS = txt2c internal_base bam
|
|
+TARGETS = bam
|
|
BAM_OBJ = $(patsubst %.c,%.o,$(wildcard src/*.c))
|
|
TXT2C_LUA = $(wildcard src/*.lua)
|
|
|
|
@@ -24,14 +24,14 @@ TXT2C_LUA = $(wildcard src/*.lua)
|
|
# make rules
|
|
all: $(TARGETS)
|
|
|
|
-txt2c: src/tools/txt2c
|
|
+src/tools/txt2c: src/tools/txt2c.c
|
|
|
|
-internal_base: src/internal_base.h
|
|
-
|
|
-src/internal_base.h:
|
|
+src/internal_base.h: src/tools/txt2c
|
|
src/tools/txt2c $(TXT2C_LUA) > src/internal_base.h
|
|
|
|
-bam: txt2c internal_base $(BAM_OBJ)
|
|
+src/main.o: src/internal_base.h src/main.c
|
|
+
|
|
+bam: $(BAM_OBJ)
|
|
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(BAM_OBJ) $(LIBS)
|
|
|
|
test: $(TARGETS)
|
|
--
|
|
2.10.0
|
|
|