forked from hasufell/hasufell-repository
16 lines
441 B
Diff
16 lines
441 B
Diff
Source: Gentoo
|
|
Upstream: unknown
|
|
Reason: fixes underlinking
|
|
|
|
--- CMakeLists.txt
|
|
+++ CMakeLists.txt
|
|
@@ -392,7 +392,7 @@
|
|
message(FATAL_ERROR "Unix port requires pthreads support.")
|
|
endif()
|
|
set(ALLEGRO_HAVE_LIBPTHREAD 1)
|
|
- list(APPEND PLATFORM_LIBS m ${CMAKE_THREAD_LIBS_INIT})
|
|
+ list(APPEND PLATFORM_LIBS dl m ${CMAKE_THREAD_LIBS_INIT})
|
|
list(APPEND PLATFORM_SOURCES ${ALLEGRO_SRC_UNIX_FILES})
|
|
|
|
if(WANT_OSS)
|