forked from hasufell/hasufell-repository
19 lines
512 B
Diff
19 lines
512 B
Diff
From: Julian Ospald <hasufell@gentoo.org>
|
|
Date: Fri May 23 16:59:33 UTC 2014
|
|
Subject: make optimization level build-type dependant
|
|
Upstream: no, doesn't care
|
|
|
|
--- hiawatha-9.5/CMakeLists.txt
|
|
+++ hiawatha-9.5/CMakeLists.txt
|
|
@@ -2,7 +2,9 @@
|
|
project(Hiawatha C)
|
|
|
|
# Compiler
|
|
-set(CMAKE_C_FLAGS "-O2 -Wall -Wextra ${CMAKE_C_FLAGS}")
|
|
+set(CMAKE_C_FLAGS "-Wall -Wextra ${CMAKE_C_FLAGS}")
|
|
+set(CMAKE_C_FLAGS_RELEASE "-O2")
|
|
+set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2")
|
|
set(CMAKE_BUILD_TYPE "RelWithDebInfo")
|
|
|
|
# Options
|