Upstream: yes, cherrry-picked from master
Reason: Fix build with boost[>=1.69.0] which removed the signals lib

From 72a634ef6262dc1401298adb28000d1c89442482 Mon Sep 17 00:00:00 2001
From: geoffthemedio <geoffthemedio@gmail.com>
Date: Fri, 26 Oct 2018 09:06:46 +0200
Subject: [PATCH] Remove all references to signals library from CMakeLists.txt

---
 CMakeLists.txt    | 5 -----
 GG/CMakeLists.txt | 2 +-
 2 files changed, 1 insertion(+), 6 deletions(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 927c8c165..8d3832049 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -205,7 +205,6 @@ find_package(Boost ${MINIMUM_BOOST_VERSION}
         log_setup
         regex
         serialization
-        signals
         system
         thread
     REQUIRED)
@@ -357,7 +356,6 @@ target_link_libraries(freeorioncommon
     ${Boost_LOG_SETUP_LIBRARY}
     ${Boost_REGEX_LIBRARY}
     ${Boost_SERIALIZATION_LIBRARY}
-    ${Boost_SIGNALS_LIBRARY}
     ${Boost_SYSTEM_LIBRARY}
     ${Boost_THREAD_LIBRARY}
     ${ZLIB_LIBRARIES}
@@ -668,8 +666,6 @@ if(APPLE)
            ${CMAKE_COMMAND} -E copy_if_different "${Boost_PYTHON_LIBRARY}" "$<TARGET_FILE_DIR:freeorion>/../SharedSupport"
         COMMAND
            ${CMAKE_COMMAND} -E copy_if_different "${Boost_SERIALIZATION_LIBRARY}" "$<TARGET_FILE_DIR:freeorion>/../SharedSupport"
-        COMMAND
-           ${CMAKE_COMMAND} -E copy_if_different "${Boost_SIGNALS_LIBRARY}" "$<TARGET_FILE_DIR:freeorion>/../SharedSupport"
         COMMAND
            ${CMAKE_COMMAND} -E copy_if_different "${Boost_SYSTEM_LIBRARY}" "$<TARGET_FILE_DIR:freeorion>/../SharedSupport"
         COMMAND
@@ -769,7 +765,6 @@ if(WIN32)
         boost_python-vc90-mt-1_44.dll
         boost_regex-vc90-mt-1_44.dll
         boost_serialization-vc90-mt-1_44.dll
-        boost_signals-vc90-mt-1_44.dll
         boost_system-vc90-mt-1_44.dll
         boost_thread-vc90-mt-1_44.dll
         glew32.dll
diff --git a/GG/CMakeLists.txt b/GG/CMakeLists.txt
index 1e5f29d93..238cc44d0 100644
--- a/GG/CMakeLists.txt
+++ b/GG/CMakeLists.txt
@@ -91,7 +91,7 @@ if(NOT USE_STATIC_LIBS)
 endif()
 
 set(Boost_USE_STATIC_LIBS ${USE_STATIC_LIBS})
-find_package(Boost ${MINIMUM_BOOST_VERSION} COMPONENTS date_time filesystem regex signals system thread log REQUIRED)
+find_package(Boost ${MINIMUM_BOOST_VERSION} COMPONENTS date_time filesystem regex system thread log REQUIRED)
 
 find_package(OpenGL REQUIRED)
 find_package(GLEW REQUIRED)
-- 
2.20.1